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General  
 
With Contacts Manager application you can export contacts from Nokia 92xx into textual file (CSV, 
TXT) with delimiters. Exported data can be imported into the sheet or database application etc.  
 
Export 
 
By pressing Export contacts button (or under Menu->Contacts->Export contacts) you can store data 
from primary contacts database (in communicator) into text file with delimiters (format can be set 
under Options button, by default CSV format, comma is delimiter, quotes are string qualifier). In the 
dialogue windows select filename, its extension and also folder for saving it. Wait until export is 
finished. 
 
If you want to export content of MMC database then press Export from MMC button (or select Menu-
>Contacts->Export from MMC). 
 
Settings 
 
By pressing Options button you can open settings: 
Cell separator – delimiter can be either comma or semicolon (CSV format) or tab (TXT format).  
String qualifier – there can be used quotes/apostrophes/nothing as a delimiter in CSV format 
(commas/semicolons delimited), TXT format (tabs delimited) usually doesn’t use text qualifier. 
 
Caution: 
Don't use "None" option in string qualifier settings together with commas/semiciolons delimiters unless 
you have good reason to do so. This qualifier option is recommended only for usage together with 
"Tab" delimiters. 



Format and structure of exported file 
 
As a result of export you will get delimited textual file with the data ordered into 79 “columns” (v.0.91). 
Delimiters are either commas or semicolons (CSV format) or tabs (TXT format) depending on your 
choice. Unicode coding is used.  
 
Columns headers and their order:  
 
Header Info Exclusivity 
ID Unigue ID of the contact card  
Last name Family name field Single 
First name Given name field Single 
Middle name Additional name field Single 
Title Name prefix field Single 
Suffix Name suffix field Single 
Birthday Birthday field Single 
Birthday desc. User string in Birthday (.....) field if exists  
Ringing tone Path and filename of the contact’s individual ringing tone Single 
Company Organization name field Single 
Job title Job title field Single 
Tel Default Tel field Multi 
Tel (Preferred) Tel field with property Multi 
Tel (Business) Tel field with property Multi 
Tel (Private) Tel field with property Multi 
Tel (Car) Tel field with property Multi 
Tel (Data) Tel field with property Multi 
Other Tel Tel field renamed with user string Multi 
Other Tel desc. User string in Tel (.....) field if exists  
Tel GSM Default Tel GSM field Multi 
Tel GSM (Preferred) Tel GSM field with property Multi 
Tel GSM (Business) Tel GSM field with property Multi 
Tel GSM (Private) Tel GSM field with property Multi 
Tel GSM (Car) Tel GSM field with property Multi 
Tel GSM (Data) Tel GSM field with property Multi 
Other Tel GSM Tel GSM field renamed with user string Multi 
Other Tel GSM desc. User string in Tel GSM (.....) field if exists  
Pager Default Pager field Multi 
Other Pager Pager field renamed with user string Multi 
Other Pager desc. User string in Pager (.....) field if exists  
Fax Default Fax field Multi 
Fax (Preferred) Fax field with property Multi 
Fax (Business) Fax field with property Multi 
Fax (Private) Fax field with property Multi 
Fax (Mobile) Fax field with property Multi 
Fax (Car) Fax field with property Multi 
Other Fax Fax field renamed with user string Multi 
Other Fax desc. User string in Fax (.....) field if exists  
Mail Default Mail field Multi 
Mail (Preferred) Mail field with property Multi 
Mail (Business) Mail field with property Multi 
Mail (Private) Mail field with property Multi 
Other Mail Mail field renamed with user string Multi 
Other Mail desc. User string in Mail (.....) field if exists  
URL Default URL field Multi 
URL (Business) URL field with property Multi 
URL (Private) URL field with property Multi 
Other URL URL field renamed with user string Multi 
Other URL desc. User string in URL (.....) field if exists  



DTMF Default DTMF field Multi 
Other DTMF DTMF field renamed with user string Multi 
Other DTMF desc. User string in DTMF (.....) field if exists  
P.O. Box Address field Single 
Extension Address field Single 
Street Address field Single 
ZIP / postal code Address field Single 
City Address field Single 
State / province Address field Single 
Country Address field Single 
P.O. Box (Business) Business address field Single 
Extension (Business) Business address field Single 
Street (Business) Business address field Single 
ZIP / postal code (Business) Business address field Single 
City (Business) Business address field Single 
State / province (Business) Business address field Single 
Country (Business) Business address field Single 
P.O. Box (Private) Private address field Single 
Extension (Private) Private address field Single 
Street (Private) Private address field Single 
ZIP / postal code (Private) Private address field Single 
City (Private) Private address field Single 
State / province (Private) Private address field Single 
Country (Private) Private address field Single 
Note Default Note field Multi 
Other Note Note field renamed with user string Multi 
Other Note desc. User string in Note (.....) field if exists  
Misc. Various conceded, hidden and special fields and items  
Misc. - type Property/type/subtype tag to specify type of „Mics.“ item  
Misc. desc. User string in the field „Misc.“ if exists  
 
If there is “multi-field” (i.e. repeating fields) in any contact card then multi-lining (with repeated lines) is 
used for export of such contact and in this case contents of five “name-regarded” fields (never 
repeatable in contact card) – “Last name“ etc. – are copied into each line belonging to the same 
contact (lines with the same ID).  
 
So if  - for example – “Parker John“ contact card has three fields “Tel“, one “Tel GSM“ and two e-mail 
addresses then corresponding columns of its export will look like this:  
 
ID Last name First name ... Tel       ..... Tel GSM      ..... Mail                          ... 
865 Parker John  +999333222111 +888777000111 mail1@company.com 
865 Parker John  +999444777666    mail2@company.com 
865 Parker John  +999555000888     
 
All of these lines are related to the same contact card in the database – called John Parker. In case 
there could be another John Parker in the database he will have different ID in the first column so 
when sorting contacts for Excel etc you shouldn’t be confused by it. 
 
1584 Parker John  +999321321321 +888666555111 parker@comp.org 
 
If in doubt – in unclear situations (e.g. after sorting sheet by the “Last name” or “Company” etc) - 
please always check if these lines have same ID or not.  
 
Fields with user-defined description such as “Tel (lodge)” or “Fax (1st floor)” etc are exported as “Other 
Tel“, “Other Fax“ etc and their user-defined descriptions are displayed in the next column: 
 
Other Tel Other Tel desc.   Other Fax Other Fax desc. 
+999456456456 lodge +999789789789 1st floor 
 



Smart export features 
 
“Repair” function 
 
Although there are no real repairing functions in this version yet (application handles contacts 
database in read-only mode) note that Contacts Manager it is able to recognize incomplete “compact” 
entries that are visible in communicator’s contact card window but they are ignored by the PIMs 
(Outlook, Lotus Notes ...) during synchronizing – so they are usually omitted by syncchronizer. Though 
no such fields can be created in the communicator itself they often raise when business card is 
received via infrared or SMS, especially if sending phone sends it with contracted field headers 
(compact business card). These fields (in most cases they are telephone fields) are properly exported 
into the result file by the Contacts Manager, of course. 
 
Conceded, hidden and special fields 
 
Database entries can contain much more field types in contact cards than user can create or even see 
in the contact card window.  
Conceded (odd but visible in the contact card) and hidden (not visible) fields can only be fetched from 
the outside (via infra or SMS) not created in communicator in usual way.  
Special fields are linked to the sound or picture data and sometimes are created by another 
application in the communicator. 
 
“Conceded” fields 
 
Conceded fields are visible in the communicator’s contact card but they can’t be created here locally. 
These fields are exported into the common “Misc.” column. There are two (known) conceded field 
types – LABEL and ROLE. 
 
LABEL field contains formatted unstructured address and is displayed as a single-line “Address” field 
in the contact card.  
Note! This formatted address field must not be confused with the regular communicator’s structured 
“address” fields (P.O. Box; Extension; Street; ZIP / postal code; City; State / province; Country) that 
are encapsulated by the “Address” heading.  
 
ROLE field belongs to company data and it is displayed as a “Job description” field in the contact 
card.  
 
“Hidden” fields 
 
Following field types if imported they are stored (including their data) with the contact card but they are 
not seen in the contact card window. These fields are exported into the common “Misc.” column. 
 
FN (formatted unstructured name) 
MAILER (name of the mail client application) 
GEO (geographical information – longitude and latitude) 
SOUND (binary data or path to the sound file – it is not communicator’s ringing tone file) 
 
Hidden properties of fields  
 
Some fields (e.g. Address/Label fields) can contain subtypes (properties) that are not seen in the 
contact card window but they are stored with the contact card information (like DOM etc). 
 
“Special” fields 
 
Ringing tone – individual ringing tone of the contact person. This field has its own column in the 
exported file.  
Speed dial – speed dial key for selected phone number of the contact person. Representation of this 
field is not finalized yet in Contact Manager. 
PHOTO - contact picture file. Representation of this field is not finalized yet in Contact Manager. 



How to get the exported data into Excel 
 
Coding used is Unicode - thus you can import it directly into Excel 2000 or newer, while for importing 
into older Excel versions you have to open the Unicode-coded file e.g. in Word first and then save it – 
again in textual form – in appropriate national coding and then import it into Excel. 
 
Excel 2000 and newer 
 
To prevent distorting phone numbers during loading exported data into Excel it is important to import 
them as a “text” not “numbers”. How to reach it? 
 
User can set cells format in the empty Excel sheet as "text" but this setting is valid only for typing. As 
soon as you paste or straight-import the data into these cells then this setting is ignored and data is 
imported in "general" format. Then the phone numbers might be distorted. 
 
Before exporting you have to ensure that Options are set in a recommended way: 
Cell separator: comma (default) or semicolon (change it so if necessary) 
String qualifier: quote (default)  
You can use of course “apostrophe” qualifier if necessary but don’t use “tab” separator (delimiter) in 
case you want to import the file into Excel. 
Save the exported file with chosen name and .csv extension. 
 
If you have data exported with “tab” delimiter then file should have .txt extension and for proper 
importing such file please skip this “a” section and follow the “b” section instead. 
 
a) Having the data in CSV file 
 
If you have created comma or semicolon delimited file with CSV extension you can open it – as an 
associated file – directly in Excel by simple double-clicking on the file. Or you can use File->Open... 
 
But neither commas nor semicolons delimiters are expected as a default in Excel. So all data is loaded 
into the “A” column. That is OK. 
 
In CSV format user can use "text qualifiers" (quotes or apostrophes) but it doesn't influence the format 
in which the data is imported or pasted into cell. Text qualifier is important in case that text strings 
contain same characters as those used as delimiters so this is the way to differentiate valid character 
from delimiter. But text qualifier never ensures that text strings will be imported as text strings. This 
has to be ensured in the different way (see further). 
 
Select (mark) the “A” column containing the data and select Data->Text into columns. That will start 
importing Wizard. If you used Data->Read external data->Import text file instead of opening file you 
would get very similar wizard. 
 
In the first Wizard window choose ‘Delimited’ option and click on Next. In the second Wizard window 
choose proper ‘Delimiter’ and ‘Text qualifier’ (according to the settings in Options in Contact Manager, 
i.e. comma and quotes if it is in default recommended setting).  
Note – the ‘Treat consecutive delimiters as one’ option MUST NOT be selected (the box next to it has 
to remain empty)!  
Click on Next.  
 
Here comes the very important moment for proper format settings. First column in 'Data preview' table 
in the lower half of the third Wizard window is selected (= in black) and prepared for format change. 
But we need to set ALL columns into "text" format. So press and hold Shift key and jump to the last 
column in the preview (the fastest way is to move the slider to the rightmost edge) and click on the last 
column's header tab (with the word "General"). Now all columns should be selected (turned to black). 
Now in the ‘Column data format’ list select ‘Text’ option instead of ‘General’. Header tabs of all 
columns will change from ‘General’ to ‘Text’. 
Press Finish. 



Now data is correctly imported and phone numbers are represented properly (the "+" sign is OK, 
spaces are OK). 
 
b) Having the data in the TXT file 
 
TXT file is the case when “tab” are selected delimiters. This format doesn’t need text qualifiers so 
sometimes this option is set as “none”.  
 
Don’t us File->Open for loading the data into Excel because it would open it in the wrong format with 
distorted phone numbers. Create new (empty) sheet and select Data->Read external data->Import 
text file. Browse text files – select ‘File types: text files (*.txt)’, find your exported text file in TXT format 
(tab delimited) and press Import. That will start importing Wizard. 
 
Also in TXT format user can use "text qualifiers" (quotes or paragraphs) but it doesn't influence the 
format in which the data is imported or pasted into cell. Text qualifier is important in case that text 
strings contain same characters as those used as delimiters so this is the way to differentiate valid 
character from delimiter. But text qualifier never ensures that text strings will be imported as text 
strings. This has to be ensured in the different way (see further). 
 
In the first Wizard window choose ‘Delimited’ option and click on Next. In the second Wizard window 
choose proper ‘Delimiter’ and ‘Text qualifier’ (according to the settings in Options in Contact Manager, 
i.e. probably “tab” delimiter and “none” qualifier).  
Note – the ‘Treat consecutive delimiters as one’ option MUST NOT be selected (the box next to it has 
to remain empty)!  
Click on Next.  
 
Here comes the very important moment for proper format settings. First column in 'Data preview' table 
in the lower half of the third Wizard window is selected (= in black) and prepared for format change. 
But we need to set ALL columns into "text" format. So press and hold Shift key and jump to the last 
column in the preview (the fastest way is to move the slider to the rightmost edge) and click on the last 
column's header tab (with the word "General"). Now all columns should be selected (turned to black). 
Now in the ‘Column data format’ list select ‘Text’ option instead of ‘General’. Header tabs of all 
columns will change from ‘General’ to ‘Text’. 
Press Finish. 
Now data is correctly imported and phone numbers are represented properly (the "+" sign is OK, 
spaces are OK). 
 
Warning 
 
While working with the data table in sheet application never remove “A” column with ID data.  
When sorting items by any header (Last name, Company ...) always select ALL columns. 
Cell format has to be always set in the way so as the data is interpreted as text not as number. 
 
Also never edit/remove first line containing the export protocol identifier. 
  


